Microsoft aktualisiert Anti-Hack-Tool EMET

Microsoft hat Version 5.1 seines Enhanced Mitigation Experience Toolkit veröffentlicht. Das Update soll mögliche Konflikte mit den für heute Abend geplanten Sicherheitsupdates für Internet Explorer ausschließen. Nutzer von Internet Explorer 11 unter Windows 7 und Windows 8.1, die auch EMET 5.0 verwenden, wird daher zur Aktualisierung geraten.

EMET Icon (Bild: Microsoft)

Das Enhanced Mitigation Experience Toolkit (EMET) ist ein Hilfsprogramm, das das Ausnutzen von Sicherheitslücken in der Software verhindern helfen soll. Anwender oder Administratoren können damit für ausgewählte Programme zusätzliche Sicherheitstechnologien zur Schadensbegrenzung einsetzen, um diese nachträglich abzuhärten. Dadurch lassen sich zahlreiche Angriffsmethoden blockieren, die von Schadsoftware und Exploits ausgenutzt werden.

EMET 5.1 beseitigt mehrere Programmfehler und Kompatibilitätsprobleme mit anderen Anwendungen. Dazu zählen Internet Explorer, Adobe Reader, Adobe Flash und Mozilla Firefox. Solche Probleme lassen sich bei solch einem aggressiven Tool wie EMET nicht ausschließen, was auch der Grund dafür sein dürfte, dass es nicht fester Bestandteil von Windows ist.

Das Update liefert zudem spezielle Konfigurationen für Oracle Java 8 und Google Chrome. Zudem führt es die Funktion „lokale Telemetrie“ ein, so dass Speicherabbilder automatisch lokal gesichert werden, wenn ein Sicherheitsverstoß entdeckt wurde. Darüber hinaus korrigiert EMET 5.1 einen Fehler, durch den Einstellungen für Gruppenrichtlinien unter Umständen nicht korrekt übernommen wurden.

Laut einem Eintrag in Microsofts Security Research und Defense Blog hängen die Probleme mit den November-Updates für Internet Explorer mit dem Schadensbegrenzungsmechanismus EAF+ zusammen. Export Address Table Access Filtering Plus entdeckt von Malware eingesetze Techniken, um Windows-APIs auszuführen und auf bestimmte Funktionen der Ausführungsumgebung zuzugreifen. Statt auf EMET 5.1 zu aktualisieren, können Anwender auch EAF+ deaktivieren, um Kompatibilitätsprobleme mit Internet Explorer 11 zu vermeiden.

EMET setzt Microsoft .NET Framework 4.0 voraus. Zur Verwendung von EMET mit Internet Explorer 10 unter Windows 8 und Windows Server 2012 wird zusätzlich die Installation von KB2790907 oder einer neueren Version des Kompatibilitätsupdates für Windows 8 oder Windows Server 2012 benötigt.

Download:

Das Enhanced Mitigation Experience Toolkit (EMET) bietet eine zusätzliche Schutzschicht vor Angriffen (Bild: ZDNet.com).Das Enhanced Mitigation Experience Toolkit (EMET) bietet eine zusätzliche Schutzschicht vor Angriffen (Bild: ZDNet.com).

[mit Material von Larry Seltzer, ZDNet.com]

Tipp: Wie sicher sind Sie bei der Sicherheit? Überprüfen Sie Ihr Wissen – mit 15 Fragen auf silicon.de

Neueste Kommentare 

Noch keine Kommentare zu Microsoft aktualisiert Anti-Hack-Tool EMET

Kommentar hinzufügen

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *